PDA

View Full Version : 2010 M21 Antenna Problems



bgd43xespn
08-01-2012, 04:44 PM
This post is for informational purposes only should you have a similar problem

I wondered why the antenna reception was very poor in areas of known usable reception. I first removed the pre-amp switch from the wall only to find that the coax cable was poorly crimped and came right off the cable with very little help. I replaced the connector and still had only marginal reception. I then went to the roof and removed the omni antenna from it's post. The connector on the roof was also not crimped properly. I ran a new piece of RG6 coax down through the hole in the ceiling and after removing the door trim and loosening the bathroom wall a bit was able to feed the new cable through the hole in the stud next to the AC recepticle and out the opening for the pre-amp. I cut the cable to length and terminated with new connector and put the whole thing back together. I connected a TV, did a manual scan and VOILA!! I now had 32 channels where I started with 2.

I don't recommend this for the average person unless you are handy with RF connectors and have at least some carpentry skills. However, it is possible that my unit was not the only unit built with poor crimp connectors. You may benefit by using a service technician.

danemayer
08-01-2012, 05:11 PM
Hi bgd43xespn,

Welcome to the Heartland Owners Forum. You'll find a lot of useful information here along with a lot of friendly people willing to share their knowledge and experience.

Thanks for sharing your experience.