PDA

View Full Version : power to central vac will not turn off



pamshiles
09-26-2012, 07:55 PM
We are having a problem with our central vac in our 2011 BC 3595. At first when i plugged the hose in it would sometimes work, but sometimes it seemed like it wouldn't make a connection. Now when I pulled the hose out it would not turn off . We finally turned of the breaker that was labeled central vac but that was not the correct one. We turned off the one that says converter and it went off. We were hoping that maybe it would reset after that breaker was off for 24 hours but when we turned the breaker back on it still turns the vac on
Has anyone had this problem and can help?

boatto5er
09-26-2012, 08:40 PM
The sliding part of the door has become misaligned. Happened to us a couple of weeks ago. You'll have to "play" with the door until it moves freely (sliding up and down).


Sent from my iPhone using Tapatalk

wdk450
09-26-2012, 11:25 PM
In your storage area crawl space the vacuum and the convertor are plugged into the wrong outlets (switched). I found the same mistake on mine. Most people will never notice it. If you want, you can just change the labeling on the breakers. You can verify which is your convertor breaker by turning on some 12 volt lights, putting a DC voltmeter across the battery, and turning off breakers. You will see the DC voltage on the voltmeter decrease when you turn off the convertor breaker.

ILH
09-27-2012, 05:34 AM
We have the same issue on our new Road Warrior. We will be delivering our unit to the dealer for the end of season warranty reapair (we have a list of items requiring attention). At the moment we use the breaker to turn the vacuum on and off.

If you search the forums, you'll see that the vacuum and switch have had a few issues lately. It's a dealer repair item.