PDA

View Full Version : Tv/dvd player problems



Ragnasty
01-21-2013, 04:52 PM
In my new 2013 elkridge 37 ultimate. I have a genisis entertainment unit and a toshiba 32" tv. Problem is, when a dvd is put in, it only plays in black & white! Anyone else have that problem

jimtoo
01-21-2013, 06:54 PM
Hi Ragnasty,

Welcome to the Heartland Owners Forum and Family. We have a great bunch of people here with lots of information and all willing to share their knowledge when needed.

I'm sure you will get some help with your dvd soon... I'm thinking it happen to me for a couple times and I found that I had a bad connection on one of the cables out to the TV. Mine quite completely a couple of weeks ago, so I will be replacing it soon. You might check with another cable or check connectors.

Think about joining the Heartland Owners Forum (//heartlandowners.org/content.php/128) and making some of the rallies when you can. You will meet some of the best people and eat the best food around.

Enjoy the forum and your new Elkridge.

Jim M

danemayer
01-21-2013, 06:55 PM
Hi Ragnasty,

Congratulations on your new Elkridge and welcome to the Heartland Owners Forum. There's a lot of useful information here along with a great bunch of friendly and helpful people.

The black & white output could be 1) poor connection; try reseating the connectors at both ends, or 2) menu settings on the Genesis. Here's a prior thread (//heartlandowners.org/showthread.php/27912-New-3685RL-Entertainment-System?p=245172&highlight=genesis#post245172)discussing the same thing.

TXTiger
01-21-2013, 10:28 PM
Maybe it's an old black and white movie, lol lol lol. Just kidding. Sounds like a bad cable connection. You said that your rig is a new 2013. Have it checked under warranty if you are near a dealer.