PDA

View Full Version : Lag time when using RV Lock



RoadJunkie
03-25-2014, 09:09 PM
James, great to have you monitoring this forum. If I may, I do have a question: We picked up RVlock in Quartzsite and installed the lock and remote keypad soon after. I don't understand why the remote keypad takes a couple of attempts prior to a successful operation of the lock. I have been deliberate while pressing in the code and press each button for at least 2 seconds, as was suggested by a Lippert rep. What can I do to make each operation successful? Thanks.

RVLockSupport
03-26-2014, 07:42 PM
I think that we should be able to take care of you, please go to support@rvlock.com and email us your postal mailing address so that I can send you a replacement part that should take care of what you are experiencing. Please simply remind our support team of what you are facing and request the part and we will send it out to you at our expense. We are always looking to improve our products and appreciate our support group in the field. Travel safe. Thanks!

porthole
03-28-2014, 09:40 PM
What is the part?

I called several months with almost the same issue and I was invited to remove the lock and send it back and for a $ fee a replacement lock would be sent out, and while waiting leave, my door "latch-less"

RVLockSupport
03-29-2014, 12:03 AM
What is the part?

I called several months with almost the same issue and I was invited to remove the lock and send it back and for a $ fee a replacement lock would be sent out, and while waiting leave, my door "latch-less"
I am very sorry for your inconvenience. 99% of every handle exchange that we have done has been through the "on your honor" system. In other words we send out a replacement and after the new handle is installed, we then request the defective one back. We don't want to leave you without handles. We are very fortunate as a company and want to pass along that same Karma. Please contact us and let us take care of you. :)