PDA

View Full Version : RV lock 4.0 not working



tlkidd
07-18-2017, 04:43 PM
My RVLock (purchased in Dec. 2014) has recently stopped locking the rv when using the remote but will unlock it. A few weeks ago I discovered that the lock mechanism isn't locking when I input the code either with the touch pad or the remote fob. The mechanism does work to unlock if you lock it with a key. I have talked to RVLock and bought two new circuit boards. With the new touch pad board the lock works but the mechanism only travels half the distance each time you activate it. This means you have to activate it twice to get it to lock or unlock. Has anyone else had this problem? Any suggestions?

jbeletti
07-18-2017, 05:17 PM
When you acuate the lock while the door is open, while looking into the end of the lock, does it seem like the lock is dragging?

danemayer
07-18-2017, 06:47 PM
I had this problem in 2014 as temperatures dropped below freezing. Had to press the FOB button 3 or 4 times to open or close the lock. RVLock sent a new circuit board and the problem has never recurred.

tlkidd
07-18-2017, 07:00 PM
When you acuate the lock while the door is open, while looking into the end of the lock, does it seem like the lock is dragging?
No, I have lubed it and it turns easy with the key or the inside red lever.

Jesstruckn/Jesstalkn
07-18-2017, 09:37 PM
Did you try fresh batteries ?
Also have you tried to disassemble it and lube the slide shaft with white lithium grease.
I had the same issue and that seemed to solve the problem.

Jerrod

Sent from my XT1585 using Tapatalk

Bones
07-19-2017, 05:41 AM
I had this problem with my V3 lock on the rear door. It had something to do with pressure and dragging. I had a fairly simple solution to it. I to the back plate off and removed the snap spring for the red lever. Once removed the lever is free to come out of the hole. I replaced the cover and then pushed the red lever back on the lock shaft. It has worked great since then. The lock mechanism uses friction to move the lock. If you have too much friction the lock mechanism will bind and not move via the motor. If you move it by hand it moves fine just not on its own power

tlkidd
07-19-2017, 09:21 PM
Did you try fresh batteries ?
Also have you tried to disassemble it and lube the slide shaft with white lithium grease.
I had the same issue and that seemed to solve the problem.

Jerrod

Sent from my XT1585 using Tapatalk
Yes I tried new batteries,I finally took the lock apart and found that the motor only turns one revolution with the new circuit board but the motor turns 3 revolutions with the old board but only in one direction.RVLock is sending a new motor,but I think there is still a circuit board problem.

NWILSON
07-20-2017, 06:37 AM
I had to file the rough edges off the metal stampings to remove the bind on the deadbolt

LBR
07-20-2017, 09:40 AM
I disassembled my door locks, lubed them where and with what i felt was needed, then checked them for proper operation prior to my install.

tlkidd
07-22-2017, 03:57 PM
I disassembled my door locks, lubed them where and with what i felt was needed, then checked them for proper operation prior to my install.

RV Lock sent me two more boards and a new motor. After trying the new motor with old key pad and not working tried with new touch pad board. Everything work okay now. So it. Took a new key pad board and motor to get it working again. Special thanks to RVLock for working with me and getting us back on the road. My wife really likes this lock. Terry

LBR
07-22-2017, 04:55 PM
RV Lock sent me two more boards and a new motor. After trying the new motor with old key pad and not working tried with new touch pad board. Everything work okay now. So it. Took a new key pad board and motor to get it working again. Special thanks to RVLock for working with me and getting us back on the road. My wife really likes this lock. TerryCompanies like this can be a rare find nowadays with such great service and support....so refreshing to do biz with them.

RVLockSupport
07-27-2017, 01:04 PM
RV Lock sent me two more boards and a new motor. After trying the new motor with old key pad and not working tried with new touch pad board. Everything work okay now. So it. Took a new key pad board and motor to get it working again. Special thanks to RVLock for working with me and getting us back on the road. My wife really likes this lock. Terry

Good afternoon Terry. I apologize for the trouble you experienced with your handle and I'm glad our support team was able to get that resolved for you. Please let us know if you have any further questions or concerns. Have a great day.

travelin2
08-29-2017, 06:59 AM
Hello,
Our V3.0 has failed again. I have sent "support" an email, a PM via this forum, and message via their website.
I'd like a response from someone.
TIA


Sent from my iPhone using Tapatalk

Bones
08-29-2017, 08:06 AM
Hello,
Our V3.0 has failed again. I have sent "support" an email, a PM via this forum, and message via their website.
I'd like a response from someone.
TIA


Sent from my iPhone using Tapatalk
Lyle how many does this make?

travelin2
08-29-2017, 10:50 AM
Lyle how many does this make?

Second circuit board, will need a third!
Second keypad, membrane is already failing on it.
Junk...


Sent from my iPhone using Tapatalk

Dumboldles
08-29-2017, 11:59 AM
Gosh I wanted this product to work, but after giving it a try and having the whole system including the key mechanism portion fail when trying to open the door in over 100 degree, I put the original system back on.

yes, customer service was terrific in sending out a replacement system, but I'm going to stay with the original door lock system that came with my rig.

Dumboldles

pegmikef
08-29-2017, 04:01 PM
I guess I have been lucky because I have had my V4 almost four years and in 42K plus miles on my BH, I have only had to replace the membrane once. The lock has worked as advertised the whole time. Had a slight problem finding batteries for the key fob, but found them on Amazon. I called customer service and when they called me back they gave me several places one of which was Walmart (our local Walmarts don't carry them for some reason).

Jesstruckn/Jesstalkn
08-29-2017, 04:49 PM
Same here we have 4 of them counting all of our basement doors and all have been working perfectly. Have changed the batteries about every 6 to 8 months but we use them alot year round.
Love my RV locks

Sent from my XT1585 using Tapatalk

travelin2
08-30-2017, 05:05 PM
Well, I finally connected with RV Lock and I am satisfied with the outcome...Another new circuit board is on its way. Still very unhappy with the V3.0 performance, two replacement boards in less than 2 years. May be a 4.0 owner in the not too distant future


Sent from my iPhone using Tapatalk

boatto5er
08-30-2017, 11:28 PM
Second circuit board, will need a third!
Second keypad, membrane is already failing on it.
Junk...


Sent from my iPhone using Tapatalk

On the other hand, we've had our V3.0 for four years and except for changing the door batteries twice and the keypad batteries each year, it has been bulletproof. Our keypad is attached by Velcro and we put it in the truck while we are traveling.


Sent from my iPhone using Tapatalk

imafader
11-29-2017, 02:21 PM
where is this circuit board you are talking about? Mine is completely dark and I have checked 12v fuses

danemayer
11-29-2017, 03:11 PM
where is this circuit board you are talking about? Mine is completely dark and I have checked 12v fuses

The RVLock is completely independent of the trailer wiring and fuses.

Have you replaced the 4 AA batteries inside the lock - accessed from inside the coach by removing a couple of screws from the cover plate? Also, I think there may be a switch on the inside that disables operation of the keypad and fobs.

Here's a link (https://manuals.heartlandowners.org/?man=/Exterior/Doors/RV%20Lock%20Keyless%20Entry) to the RVLock manuals.