PDA

View Full Version : EF 30b Fireplace Bug



Rydrcoach
03-29-2019, 04:43 PM
Well gang seems as if we've contracted the Electric Fireplace virus. The 26" curved fireplace in the bedroom of our 2019 3560SS Big Country lights up nicely and works great until the room temps are 60 degrees or lower, then nothing...does not turn on. If the room warms up the fireplace will turn on but if we turn the heating element on it will run for two minutes max then shut off. After about an hour or so it will turn back on. Supposed to rain tomorrow so I may as well tear into it. If it isn't a loose connection it will be a call to Heartland. :p

Rydrcoach
04-04-2019, 02:13 PM
Well gang seems as if we've contracted the Electric Fireplace virus. The 26" curved fireplace in the bedroom of our 2019 3560SS Big Country lights up nicely and works great until the room temps are 60 degrees or lower, then nothing...does not turn on. If the room warms up the fireplace will turn on but if we turn the heating element on it will run for two minutes max then shut off. After about an hour or so it will turn back on. Supposed to rain tomorrow so I may as well tear into it. If it isn't a loose connection it will be a call to Heartland. :p


Update: New fireplace on the way from Heartland. A few pictures and cut the power cord and they are sending one out. Hope the new one works better..

Rydrcoach
06-16-2019, 04:55 PM
The new one worked great right after install. Took a trip to norhtern Idaho where the temps dropped to mid 20's overnight. Replacement fireplace worked as well as the one we took out. Same issues. Done with it.