Cyclone 3110 - problem with sound of radio in the garage

Good sunday, maybe one of you can help us again. When we opened our rv 2 weeks ago, my husband reverse battery hook up…. The fuse on converter (pd9200) burned and we have to change 3 fuse 30 amp. on converter and all was good after. But the radio in the garage works (power) but no sound on speaker inside and no sound outside. We read the user manuel and we have to check if a fuse on the radio burned and we don’t know how remove the radio in the case. All the fuse in the rv are good. Merci beaucoup

Cynthia et Denis
 

Attachments

  • 0048D2B1-CDB7-4760-B093-ACC6D7397649.jpeg
    0048D2B1-CDB7-4760-B093-ACC6D7397649.jpeg
    1.3 MB · Views: 12
  • 372A994B-5856-41BC-BE1C-E91B3E02C1B8.jpeg
    372A994B-5856-41BC-BE1C-E91B3E02C1B8.jpeg
    922.3 KB · Views: 12

wdk450

Well-known member
As a retired electronics tech I would guess that the reversed polarity blew out the audio signal circuitry (audio driver transistors or IC ?).
I think you need a new radio.
 

david-steph2018

Well-known member
The way the pic looks, it would seem the whole case would need to come down, as there appears to be screws into the ceiling. So, wondering if the radio sits inside the case, then mounted to the ceiling.
 

Hollandt

Active Member
Good sunday, maybe one of you can help us again. When we opened our rv 2 weeks ago, my husband reverse battery hook up…. The fuse on converter (pd9200) burned and we have to change 3 fuse 30 amp. on converter and all was good after. But the radio in the garage works (power) but no sound on speaker inside and no sound outside. We read the user manuel and we have to check if a fuse on the radio burned and we don’t know how remove the radio in the case. All the fuse in the rv are good. Merci beaucoup

Cynthia et Denis
Not familiar with that system but make sure the input is set to am or FM radio and not AV and also check the output channel. Typically you have the ability to go to TV, speakers 1(a) and/or speakers2(b) for the output. Since the power has been off it could have defaulted to something else?
 
Top