PDA

View Full Version : Jack and motor problems



Mallard
04-26-2010, 10:10 AM
I own a 2009 Sundance 2900 MK and I have had nothing but problems with the jack motors and landing gear units. The first gear motor failed 20 days after purchasing new and was replaced under warrant, 9 months later it failed again and was replaced with a new improved unit. Last month the drivers side landing gear failed and this month the passenger side failed. This is 4 failures in 23 months, is any one else having similiar problems? Heartland and the manufacturer refuse to help with this and state that it must me over extended or retracted. I have owned 3 other fifth wheels and have never had jack problems and this unit only get used 3 time a year,

westxsrt10
04-30-2010, 02:32 PM
There are several threads showing how to avoid the problems you are having. I have posted on this myself.

TGLBWH
04-30-2010, 03:17 PM
I own a 2011 Elk Ridge and have already had jack problems. I think if you look this has got to be the number 1 problem. Like you, before this I had never had jack problems and my last 5th was 17 yrs old

jpajax
04-30-2010, 03:55 PM
You kinda wonder if the legs are lose or binding in the housing that it slides in.

westxsrt10
04-30-2010, 04:28 PM
You kinda wonder if the legs are lose or binding in the housing that it slides in.

It's the motors.....if your run the motor to the stop up or down its like a dead short and trips the fuse. Painting limit stripes on the leg post should stop the issues, did on mine so far.