PDA

View Full Version : Duramax Turbo Heat Shield Noise



navyAZ1
09-10-2009, 09:37 AM
We have a 07 Classic 2500HD with the Duramax and we keep hearing a strange noise when the engine is at 1100 to 1300 rpms. Dealer says it is the edge of the Turbo Heat Shield just slightly touching the engine that causes this. The dealer tweeked on the shield with a large screw driver and it stopped for a couple of weeks but came back. Another dealer did the same thing and again short time later the noise is back. Has anyone else had this problem and if so what did you do to get rid of this? The noise is like a very loud cricket and is quite embarassing at times when folks in the campground stare at us.:confused:

Bob&Patty
09-10-2009, 04:02 PM
Navy, if you can wait until tomorrow when I get to work. I will find out if there is a repair for that issue. Maybe one of the heavy line guys has seen that problem and knows the repair. Bob:D

navyAZ1
09-13-2009, 01:58 PM
Navy, if you can wait until tomorrow when I get to work. I will find out if there is a repair for that issue. Maybe one of the heavy line guys has seen that problem and knows the repair. Bob:D

Hey Bob, that will be fine I have lived with this for months so far certainly a couple of days won't make any difference.

sailorand
09-13-2009, 03:19 PM
Navy,
I have had this noise for a long time. Thier solution, nothing to worry about. Hope you find out what it is so I can fix it also

Bob&Patty
09-13-2009, 06:57 PM
My bad guys. I forgot (crs). Will make myself a note and check on Monday. Navy is your TV a classic 07 or the new body style?? Bob:o

Bob&Patty-DW
09-14-2009, 09:39 PM
Navy and sailor, did a bulletin search today and found nothing on this issue. Talked to all the heavy line techs, we have never had one doing that. 1 tech said that you might have a crack in the shield at the mounting bolts. I was going to suggest the ol' big screwdriver trick but guess that didnt work. :( Bob:D