PDA

View Full Version : Problems with converter burning up?



taminator
10-26-2013, 11:01 AM
Sorry this is short and to the point but we're out in Junction Tx, having to use wifi at office and almost no cell service at site. We think the converter went bad/is going bad on our 2014 Cyclone 3800. Could smell something electrical burning and then smoke starting filling the RV from the vent that's to the left of the fireplace. Called Coach Net at 9pm last night, talked to a tech (that was his thought too that it's the converter), we turned the breaker off to the converter (inside), turned electric back on and still same thing. We are running just off the battery now.

Any ideas? We are supposed to have a mobile mechanic come in a few hours. Just stuck and have no clue what to do. Called our sales guy but only so much he can do. The nearest Explore USA (dealership we bought from) is 70 miles away. Their service is closed on Saturday and they have to get authorization from their GM for us to even drop the thing off (if that's what we need to do). OMG and then the warranty issues: we have to pay for parts/labor, if it's over $500 they'll possibly reimburse, if over $500 have to get preauthorization, etc, etc, etc. I will be bald by the end of the day from pulling my hair out.

What a nightmare. We have never had anything happen on the road.

jnbhobe
10-26-2013, 11:52 AM
Go to Wal-mart and buy a battery charger that will keep everything working till you can service the converter. Call Heartland on Monday about your warranty issues.

cookie
10-26-2013, 11:57 AM
Let me get this straight, you turned off the breaker for the converter and still got the burning smell. Is that correct?
I would remove the wall in the basement and look around, or smell around. It may not be your converter.
What I don't understand is the $500 for warranty.
If you get a mobile tech out, you need to get preauthorization from Heartland. I don't think they will pay for the trip, but may cover parts and labor.
Others will chime in here I'm sure.

On edit, the battery charger that Jon mentioned is a good idea.
I ran my unit on a battery charger for a couple of weeks last winter in Texas.

Peace
Dave

scottyb
10-26-2013, 12:07 PM
Go to Wal-mart and buy a battery charger that will keep everything working till you can service the converter. Call Heartland on Monday about your warranty issues.

Great idea. The converter should just plug in to a standard recepticle. Very easy replacement if you feel up to it.

Also, there has been a history of loose wiring in the automatic transfer switches. If you unplug the converter, and the condition persists, check the ATS (assuming you have a generator/generator prep). My 1st ATS burned up the 2nd day I had it. It was obvious when I opened it, it smelled charred. Then another went out 6 months later. I traced that issue back to poorly landed wiring in the j-box outside the generator. The ATS's seem to be very vulnerable to loose wiring connections.

JohnDar
10-26-2013, 03:04 PM
First thing I'd do is physically look at the converter and determine manufacturer and model info, as well as it's appearance (smoked??). Then contact the manufacturer of the converter. If the rig is still under warranty, there's a good chance the converter is too. They may offer a significant price cut or replacement to you. As mentioned, there are only two wires to connect and a 120V plug to insert into an outlet. Very simple to replace, if you can get to it.

danemayer
10-26-2013, 04:17 PM
Hopefully the mobile tech will determine what's wrong and either fix it or give you a workaround.

Normally, we're expected to take our trailers back to the selling dealer for service, or at least to an authorized Heartland dealer if we're on the road. The dealer just handles the problem and we get back a working trailer. The details of how the warranty works are in the background. But when circumstances preclude this, and we put ourselves in the middle of the warranty process, we find out more than anyone wants to know about how the warranty is administered.

Any time you want to use a non-Heartland dealer or independent servicer for warranty work, Heartland requires prior approval. In this case, I'd suggest you call Heartland 1st thing on Monday and explain that the failure occurred after Heartland's offices closed on Friday and you had to get someone out due to the severity and urgency of the problem. I'd expect them to be flexible about covering labor charges. Travel time is not normally covered by warranty however, so you may get stuck with that. One possible hitch is that appliances and some subsystem parts are warranted by their providers, not by Heartland. You may end up having to talk to the provider about reimbursement of labor/travel charges if the tech requires payment up front.

Another wrinkle is that while parts should be covered under warranty on a 2014 model, most RV applicance/parts vendors use standard ground shipping for warranty. Maybe in this situation they'll expedite any needed parts at no charge. But worst case you might have to pay for expedited shipping to get the part quickly.

Hope it all gets resolved quickly without too much hassle.

hoefler
10-27-2013, 07:49 AM
Could it be the fireplace???? Is it the first time you have used it?????

JohnDar
10-27-2013, 08:47 AM
Thinking some more on this, do your 12V systems work and is the battery being charged? A dysfunctional converter might not support them. Additionally, the area where many converters have been installed is not the cleanest place (dust, debris, congestion). It would still be a good idea to physically locate and inspect it, possibly even relocate it.

taminator
10-27-2013, 10:00 AM
Could it be the fireplace???? Is it the first time you have used it?????

We used it on our last trip and no problems at all, although when we first started it up we got a funny smell (like how some new electronics will smell burning off dust). We have not used the fireplace this trip though. My husband, me and a guy camping next to us starting investigating yesterday (no repair person ever came - more on that later). Through the process of elimination we believe we have narrowed it down to an issue w/ the fireplace but still not 100% sure. So we turned the breaker off and we'll deal with it after our trip. Problem seems to be resolved for now.

That is a very scary feeling to have smoke filling up your RV and it's not from overcooked food!

We truly appreciate everyone's replies and I'll respond to each when we get to our next stop. We're getting ready to pack up now and continue on. The wifi where we are is not the best. All the info on threads like these really help when trying to trouble shoot problems in the future. That's the first thing I did yesterday was search previous threads.

jmgratz
10-27-2013, 10:01 AM
If I understood you right the smell and some smoke came out from around the fireplace. Our fireplace in our first Landmark did the same thing and it was a defective fireplace. BTW if you need a converter I got a new 70 amp one I could sell to you. PM me if interested. The post about the inexpensive battery charger does work as we did that when out converter went out after a power surge.

wdk450
10-27-2013, 03:50 PM
Sometimes the smoke smell can linger on long after the power is cut to the offending device. So troubleshooting by smell can be tricky. Finding smoke marks/char is a (forgive the term) "smoking gun".