PDA

View Full Version : Greystone Fireplace??



kakampers
01-18-2014, 08:29 PM
Anybody have the motor that runs the "flame" in their Greystone fireplace go up? If so, where did you find a replacement motor??:confused:

Ours started making a horrible racket...when we opened the fireplace, you can see the motor shaking as it tries to turn, but can't...geez....

kakampers
01-19-2014, 08:05 AM
Anybody???

danemayer
01-19-2014, 08:26 AM
Hi Ken and Kathy,

Here's a link to a Greystone manual. (http://www.factoryrvsurplus.com/files/Fire_Place_Owners_Manual0001.pdf) Not sure if it's the one you have. Also I don't see parts info or contact info.

You might try asking Heartland Customer Service for the manufacturer's contact info - if you get it, post it here.

kakampers
01-19-2014, 08:42 AM
Thanks Dan! That's it. It also appears to be identical to the FMI unit listed in your owner's manual section...that actually has a parts list with "blow up" of the entire unit. I will call FMI tomorrow to try and get a new motor.

Just our luck, it appears we are the ONLY ones this has happened to...go figure!! LOL

sengli
01-20-2014, 06:38 PM
I had to replace the control board on ours under warranty. When the furnace ran, it gave out no heat. But the motor going out..... no I havent had that happen yet. Just call FMI up, or who ever is the current vendor( look in the blue owners bag for the manual) and they will send out the parts to you. Or you could go to your dealer and maybe htey can do it for you. There really isn't much to the units once you pop them out.

Majestic
04-06-2014, 07:28 PM
Has anyone had the issue that the lights don't go off. We have to unplug ours from the wall and then plug it back in again if we want to use it