PDA

View Full Version : Halftime oven issue - shuts off after 2 minutes, then resets



NSNorthtrail
07-30-2009, 06:33 PM
Hi All,
Going out for the first time tomorrow in my new 28BHS. Going for a week. Tonight I tried to cook some items in the micro and it shut off after 2 or so mins of cooking. Completely shut off. Didnt seem to have power at all. I checked the breaker and my gfi(to my house outside plug) plug and nothing was wrong. After a few mins it came back on. Tried cooking again and it did the same thing! I am thinking that maybe because the trailer is pluged only into my house and not a proper 30 amp is the problem. But if I understand correctly that would simply trip my gfi on the plug at the house. Looking for assisstance

Dragoon
07-30-2009, 10:15 PM
This happened to us and is discussed elsewhere on this forum. Turned out to be the cooling fan was NOT functioning properly. Long story short, we now have a new unit, exchanged under warranty and has been working fine to date. Call the Apollo warranty number, they're really helpful. Hope this helps...

wdk450
07-31-2009, 10:57 AM
This happened to us and is discussed elsewhere on this forum. Turned out to be the cooling fan was NOT functioning properly. Long story short, we now have a new unit, exchanged under warranty and has been working fine to date. Call the Apollo warranty number, they're really helpful. Hope this helps...

We also had the same problem. I have heard that it is quite common with a certain production run of the ovens. Exchange is the cure.

csalmons
07-31-2009, 01:20 PM
Please call 1-800-772-7262 for assistance with your Apollo unit. It is hard to verify what the problem could be from your post. We would be happy to help you out! Thanks.