Dometic Tstat issues start with E1, then E5 now what seems to be low voltage to tstats (both)


Hello All,

My first post, although I have been reading the forum since my purchase in 2020 of my 2017 Landmark 365 Madison. Thanks to everyone who shares and contributes.

I began this trip down the rabbit hole with a simple E1 error in my front HVAC unit which controls the furnace.

I tried cleaning the contacts of the rj11 communication cable at both ends as well as the connections topside where the cable connects to the "dongles" (where rj11 gets an extension to the control board) and on the control board itself). This was unsuccessful so I ordered a new comm cable and waited. Yes, I did several resets to "init" as well as tried swapping actual tstats with the rear bedroom unit that was working fine, no progress.

I just ran the cable directly out of the door and straight to the topside unit to test connectivity. I was able to connect, however, am now receiving an E5 error which refers to the freeze sensor. I took the sensor out, cleaned contacts but could not clear the error code, again several resets to init and swap of tstat with the rear.

Today I received the replacement freeze sensor I ordered and planned to replace and hopefully end this saga. RV life is never that easy.....I woke to the rear tstat being non-responsive. the blue led background comes on but no function whatsoever. i have the 10 button dual Dometic Tstats both front and rear. So we cracked open the rear unit and began where i started on the front unit and was able to get connectivity but very very faint readout on the tstat and when any button pushed the readout disappears, very frustrating. I replaced the freeze sensor on the front unit but now am getting the exact same behavior (faint readouts and non responsive) as the rear.


I can trace 12v from the 12v breaker panel (i forgot, all breakers are intact and i have tried shutting off all power external AC as well as battery disconnects for up to an hour with no change) to the topside wiring harness to the control board (Dometic P/N 3212227.000), however, the rj11 ports and subsequent cable readings when tested with the multimeter show 6v on 2 of the rj11 contacts (middle 2) on the control board, 3v on another 2 (left 2 i believe) and no readings on the right 2. When testing the communication cable at the tstats (both of them) I am only reading 4.5v on the red/black wires. Isnt this supposed to be 12v? which would explain the faint tstat behavior and points to a bad control board, however, i cannot get my head around the coincidence that BOTH boards are experiencing the same fault at the same exact time.

This is the point where i thank you in advance and humbly ask for your expertise, wisdom, experience and intuition lol.

Please and Thank you.