PDA

View Full Version : LP Generator Problem



Superduty
08-30-2009, 06:51 PM
I have a 2010 Landmark Grand Canyon with the Onan 5.5 LP Generator. Since new I have been having a problem every time I run the Generator. If I have the automatic LP Transfer switch pointed to the Door side 40lb tank, the indicator always goes red. ( The transfer switch is located on the off door side, next to the other 40lb tank.) It then starts pulling LP from the Off door side tank. Needless to say after that tank runs empty the generator shuts down. Even when the other side is full. If I shut down the generator, the indicator goes green.:confused: If I try to run the furnace with the generator together the generator shuts down.:confused: When I restart the generator it will run for 3 seconds and shut down.

After a little investigative snooping I found that on the door side LP tank there is a pressure regulator, which then transfers to the off door side and goes to the other pressure regulator and automatic transfer switch. The door side tank does not go through two pressure regulators, just through the main regulator and out.

So I am wondering if there is suppose to be a pressure regulator on the door side tank or not. It goes from the tank via a 1/4 hose to the pressure regulator to a 1/2 hose, which then transfers to the main regulator.

I will also be calling the dealer monday.

Thanks for any help.

2010augusta
08-30-2009, 08:55 PM
the door side tank is suppose to have a regulator. My setup is exactly like you describe, and our generator works fine on either tank. furnace will work while the generator is running too.