PDA

View Full Version : Shock absorber



usamacdonald
06-27-2011, 09:31 AM
I have a 2010 Oakmont. I was under the trailer yesterday and noticed that one of the shocks had broken the stud off. I looked at the others and they appeared to be bent. Anyone know what type shocks these are and wether or not they are a covered part? Is this something someone esle has had happen? Is the bend normal or did something happen to cause it?
Thanks
Randy

Gaffer
06-27-2011, 02:38 PM
They bend and break because they are mounted nearly horizontal. Many have either removed them or mounted them at a more appropiate angle. I don't believe they are very effective in the OEM location.

caissiel
06-27-2011, 02:54 PM
All my shocks were bend at the axle plate.
Here is my story.
The trailer frame is designed using the method of installing the axle shocks mounts and springs under the axle. By having the plate under the spring instead of over the springs like our trailers have the distance is shortened by the thickness of the spring. Like 2 inches. I did a design drawing and determined that the design for the plates and the frame mount are Ideal for 60 Deg shock application. But since there is 2 " of less distance from the spring palte to the frame mount the angle changes to less them 30 Deg.

I extended the spring mount by 2 inches and after the shocks were installed I am back to 60Deg. I found that the trailer is more steady walking inside with the new shock location, so it most help on the road.

The first pic is the modification with the shocks perpendicular to the mount at 60Deg angle and the 2nd pic is the original location.

Please note that the modification was done while camping in Florida and did not have all my industrial tools but with grade 8 bolts and double nuts it has been great for the last 10K miles.

Birchwood
06-27-2011, 04:35 PM
Yea,my shock shafts are all bent and when I first observed them the rubber grommets were all worn and that was at 6000 miles.I ordered new rubber grommets from Limpert at $5.90 per shock and installed them myself in Florida
Drove back to Canada with them and no sign of wear so far.Lots for fifth wheels don't even have shocks so the next time they break on the Landmark they will be removed permanently.
Don't know why Heartland can't provide a reliable drive train as thats probably the MOST important part on a fifth wheel.
The maintenance on the Landmark is an on going affair but it is interesting and one always has something to do.

davidg
06-27-2011, 04:44 PM
I broke two shocks both on the same wheel front axle, that's when I noticed that I was not level when hooked up to the truck was a little low in the front, so made some adjustments to pick up the front of my BH so it would ride level and had no trouble since, and the studs are bent.
David

lwmcguir
06-27-2011, 10:24 PM
Best bet is to add a CP system and forget the shock in my opinion. Ours rides well however all of our other trailers had shocks and they worked very well.