Domestic Thermostat Not Responding Correctly

BrianM

Member
I have a Heartland Road Warrior. I went to turn on the A/C yesterday and could not get the thermostat to kick the A/C on while in Auto (A/C) mode. When I turned the A/C on and used Low or High it came right on. Fast forward to night time and I went to turn on the furnace. I could not get the furnace to kick on when selecting furnace on the thermostat. When I tried to select low or high like I did to turn the A/C on, but with Furnace selected the air unit kicked on.

Any suggestions? Thank you for your help in advance.

Brian-
 

danemayer

Moderator
Staff member
Hi Brian,

First, when the FAN is set to HIGH or LOW, the A/C blower runs continuously, whether the thermostat is set to COOL or HEAT. So when trying the A/C, you had the blower running, but perhaps no compressor. When trying the HEAT, again you had the A/C blower running, but not the furnace.

Have you fired up the furnace previously using that same thermostat? Only 1 thermostat controls the furnace.

And of course, the thermostat will only call for A/C or Furnace to run when there is at least a 2 degree difference between your set point and the air temp at the thermostat.

What year is your Road Warrior? Older units the thermostat connects to a control box above the A/C air return. A problem in either the thermostat or in the control box could explain failure of both A/C and Heat.
 

BrianM

Member
Dave,

Thank you for your reply, it was very helpful.

It has been a while since we used the furnace and I forgot that this was actually just tied to one of the thermostats. The front thermostat (in the bedroom) controls the furnace and that worked great once I set that correctly.

As for the HVAC (middle one). I did a reset on the thermostat, then I turned it on (auto) and it kicked right on and ran fine all day yesterday.

Thank you again for your help.

Brian-
 

marknewbill

Well-known member
Kinda random thought but it may help someone, I found when the battery dies on the camper (which it shouldnt, but when an accident occurs and it does) the brown out that results scrambles the thermostats. in those cases I found i need to perform the reset procedure on the thermostat to get it going again.
 
Top