PDA

View Full Version : Awesome customer service



ncrebel8
08-03-2009, 08:34 AM
Just thaught I would let everyone know that Midwest has great customer service. Back in april on our second trip with our new Bighorn 3410 the 1/2 time oven wouldnt work. When you opened the door the light came on inside, but keypads and display did nothing at all. Niki made a call to Midwest and they were extremly helpful offering to ship us a new one to wherever we would be. Since we were going home in a few days, they just sent it there and we had a new oven waiting for us when we got home from Myrtle Beach. Thanks again Midwest sales!

boatto5er
08-03-2009, 08:46 AM
Always great to hear good customer service stories. Thanks Wes.

csalmons
08-03-2009, 09:18 AM
Thank you very much for the pat on the back! Hopefully everything is now working fine with your new oven. If you have any more questions just give us a call!
Thanks again!

62cwil
08-18-2009, 11:41 AM
Yesterday I went to start my Apollo range burner and it took almost 3 min to get it to light. Prior to that my Eagle Ridge 29SBRL had been sitting for about 3 weeks with the gas turned off. Once I turned the gas on and the burner did not start I did start my generator and it cranked right up. I then tried to start the burners and took almost 3 min. Has anyone experienced this and was their an adjustment to solve or is this normal?

csalmons
08-18-2009, 12:04 PM
62cwil-
I'm not sure what the problem might be with that. Please give us a call and run it over with our tech, Bob. Our number is 800-772-7262. He isn't always in this building but his direct line is 574-532-9632. It might not be anything at all, but just to be sure, give him a call.

Hopefully that will help you out. Thanks!

62cwil
08-18-2009, 06:24 PM
I spoke to Bob and he was very helpful. First thing he had me check since I had turned gas off two days ago was to turn on the gas and then the stove and not the generator first like I did previously. He said if same thing happened then possibility of a gas leak somewhere in the system. I was at the rig when I called and when I turned on gas and started the stove it lit right up normally. He then had me turn the gas off for several hours and then turn on and start the generator first and then the stove. It did take longer for the stove to start but it did. The generator which is LP is about 3 feet from the tanks while the stove which has a smaller line and runs all the way from one side up front on the rig to about 1/2 way back on the other side. No explanation, but if generator not started first works fine.