PDA

View Full Version : propane tanks



Todd_Evans
10-12-2009, 05:09 PM
I'm a new landmark owner and have a situation with my right side propane tank working. The left one works great but the right one will not turn Indicator green and nothing gas will work any suggestions :)

htneighbors
10-12-2009, 07:54 PM
Sounds like it's empty or the regulator on that side is blocked. Try swapping it to the other side to verify it actually works.

jmgratz
10-12-2009, 08:33 PM
Had the same problem and had to change out the supply hose and regular. Works fine now.

2010augusta
10-12-2009, 08:39 PM
Couple thoughts:

Make sure you have propane in the tanks and the hoses are tight.

Make sure you rotate the tank indicator on the regulator to point the other direction, left or right.

Shut off both tanks and all appliances running on propane, then open the valves very slowly. the auto shut-off valve in the hose may have been triggered.

Switch the positions of the two tanks and see if anything changes.

Superduty
10-12-2009, 08:43 PM
I had a similar incident with my Landmark, the doorside LP tank would not turn the indicator green. I replaced the regulator, same problem. After a little testing, I then replaced the Pigtail from the tank to the small regulator on the doorside and all was good. ( As good as it can get with the small hoses and the small regulator you get from the factory, even after the new pigtail the regulator indicator would drop down when the generator was running). I then noticed when I was running my LP generator from the off door side tank the indicator was fluttering between red and green, I replaced the pigtail on that side, made it better. I was told that that the check valve in the pigtails can go bad.. Especially if there is moisture in the tank.