PDA

View Full Version : Landmark Rim Leaks



tthelen
08-13-2006, 07:36 PM
A few weeks ago I had to put the spare on due to the fact that the flat was caused by a rim weld leaking. Now, having gotten back home, I have another tire with a leaking rim. Has anyone else had this problem? Is this covered by the factory? I am thinking I'll need to change all 4. Is there a recommended type? We purchased our '05 Golden Gate in Nov '04, took possession in April '05. Spent the summer in a nearby park and finally hit the road October '05. That will give you an idea of how much traveling we've done. I doubt the problem was caused by overuse. We are not overloaded. Any help would be appreciated.

Cheryl
08-13-2006, 08:00 PM
Read this thread, should answer all your questions:
//heartlandowners.org/showthread.php?t=309&highlight=rims

tthelen
08-15-2006, 08:49 AM
Cheryl, Thanks so much! I called the rim place and they have 4 new rims heading my way. My problem was that I was only reading the the threads in the Landmark area, not in the Bighorn section. I guess I have to read both sections. Thanks again!

Cheryl
08-15-2006, 09:36 AM
You're welcome. After all, that's what we are here for, to help each other.
Another way to find answers that might already be on here (instead of rereading every single post in every thread) is to use the search button on the top right side of the page. Since the forum has grown SO much, I find it very helpful. You can find some really helpful "hints" on here as well as some very good advice.