Awning would not open


I have a 2011 Big Country and 16' Dometc 9100 weather pro. 3 weeks ago the awning would not open when I pushed the switch. after several attempts I pulled screws and pulled from the cabinet there were 6 terminal and wires. purchased switch from local rv dealer. while waiting for delivery tried to see if it was just stuck to no avail. Pushed on wires to maKE SURE THEY WERE NOT LOOSE AND TRIED HITTING THE RETRACT ON SWITCH AND IT MADE A SOUND. encouraged I pushed the extend and the awning moved and started out. my dilemma is I now have an $86 swich which I am not sure is the right switch. the original switch has 6 terminals and the new only has 4. what I would like to know if anyone else has had to buy switch and got a 4 terminal instead of 6. I saw one post where a member received a 5 post switch.
does anyone have any idea whether that is an updated replacement and is there a work around to use it. Will probably call dometic eventually for info but thought someone else may have had same experience. appreciate any advice.


Well-known member
An $86 dollar switch? Yikes, there is no way that I would have spent that much. There is usually markings on the OE switch, like a part number from the manufacturer. Just google that and I would hope you could have found a replacement one on line for a lot less that that. I know I carry extra replacement switches for the hydraulic gear, which handles very high current. That one was like $12 on line somewhere. And it has 6 terminals as well. Quite often the issue usually with dead awnings, is the electric motors in the awnings, which get exposed to all the weather outside. They just get rusted. May not be your switch or a power issue. You need to break out a DVM, and see whats there first.


Well-known member
I would say if your original switch had 6 pole/terminals and the new one has 4 poles then you have the wrong switch. When you push to open the awning, the + goes in one side of the motor and the - goes in the others side. When you push to close the + and - are reversed so the motor goes i the opposite direction. Hopefully you can take the switch back. The switch did sound really expensive but sometime the price can’t be helped.

This also might help:

Sent from my iPad using Tapatalk
Last edited: